Project

General

Profile

Bug #61235

Unable to access API due GenericJDBCException: error executing work

Added by Alexey Bobyr 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Alexey Bobyr
Category:
Scalix API
Target version:
Start date:
11/16/2018
Due date:
% Done:

90%

Estimated time:
Operation System:
--

Description

Description The server encountered an unexpected condition that prevented it from fulfilling the request.

Exception

javax.servlet.ServletException: Problem processing request method=GET URI=/api/dav/
com.scalix.api.PlatformDispatcherServlet.service(PlatformDispatcherServlet.java:53)
javax.servlet.http.HttpServlet.service(HttpServlet.java:742)
org.apache.logging.log4j.web.Log4jServletFilter.doFilter(Log4jServletFilter.java:71)
Root Cause

org.springframework.web.util.NestedServletException: Request processing failed; nested exception is org.hibernate.exception.GenericJDBCException: error executing work
org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:986)
org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:870)
javax.servlet.http.HttpServlet.service(HttpServlet.java:635)
org.springframework.web.servlet.FrameworkServlet.service(FrameworkServlet.java:855)
com.scalix.api.PlatformDispatcherServlet.service(PlatformDispatcherServlet.java:48)
javax.servlet.http.HttpServlet.service(HttpServlet.java:742)
org.apache.logging.log4j.web.Log4jServletFilter.doFilter(Log4jServletFilter.java:71)
Root Cause

org.hibernate.exception.GenericJDBCException: error executing work
org.hibernate.exception.internal.StandardSQLExceptionConverter.convert(StandardSQLExceptionConverter.java:47)
org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:111)
.....
javax.servlet.http.HttpServlet.service(HttpServlet.java:742)
org.apache.logging.log4j.web.Log4jServletFilter.doFilter(Log4jServletFilter.java:71)
Root Cause

org.postgresql.util.PSQLException: ERROR: current transaction is aborted, commands ignored until end of transaction block
org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2477)
org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:2190)
...
com.scalix.api.PlatformDispatcherServlet.service(PlatformDispatcherServlet.java:48)
javax.servlet.http.HttpServlet.service(HttpServlet.java:742)
org.apache.logging.log4j.web.Log4jServletFilter.doFilter(Log4jServletFilter.java:71)
Root Cause

org.postgresql.util.PSQLException: ERROR: relation "devicesetup" already exists
org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2477)
org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:2190)
....
org.apache.logging.log4j.web.Log4jServletFilter.doFilter(Log4jServletFilter.java:71)
Note The full stack trace of the root cause is available in the server logs.

History

#1

Updated by Alexey Bobyr 11 months ago

fix will be in scalix-platform 12.7.1.28837

#2

Updated by Alexey Bobyr 11 months ago

  • Status changed from Updated to Resolved

Also available in: Atom PDF