Project

General

Profile

Bug #61228

javax.mail.internet.ParseException: Missing start boundary

Added by Alexey Bobyr about 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Alexey Bobyr
Category:
Scalix SIS
Target version:
Start date:
10/01/2018
Due date:
% Done:

0%

Estimated time:
Operation System:
--

Description

2018-10-01 00:21:51.966 [FATAL] [ajp-nio2-8009-exec-20] Index failed
com.scalix.index.api.IndexerException: User 08800000f3dfe135-9.13.681.46: cannot get message body for directRef [0004ad95fb60fce8] (<EUHPPFNVQ16Q8G2EAJIF4H4L6TW9HNMZ@docus
ign.net>)
        at com.scalix.index.message.IndexableMimeMessage.generateDocument(IndexableMimeMessage.java:115) ~[classes/:?]
        at com.scalix.index.manager.IndexManager.createDocument(IndexManager.java:362) ~[classes/:?]
        at com.scalix.index.manager.IndexManager.indexMessage(IndexManager.java:163) ~[classes/:?]
        at com.scalix.index.web.InternalIndexerServlet.doIndex(InternalIndexerServlet.java:352) [classes/:?]
        at com.scalix.index.web.InternalIndexerServlet.doPost(InternalIndexerServlet.java:317) [classes/:?]
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:661) [servlet-api.jar:?]
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:742) [servlet-api.jar:?]
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:231) [catalina.jar:8.5.31]
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:166) [catalina.jar:8.5.31]
        at com.scalix.sis.web.IPFilter.doFilter(IPFilter.java:69) [classes/:?]
...
       at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49) [tomcat-coyote.jar:8.5.31]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:1.8.0_152]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:1.8.0_152]
        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61) [tomcat-util.jar:8.5.31]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_152]
Caused by: javax.mail.internet.ParseException: Missing start boundary
        at javax.mail.internet.MimeMultipart.parse(MimeMultipart.java:680) ~[javax.mail-1.6.2.jar:1.6.2]
        at javax.mail.internet.MimeBodyPart.getContent(MimeBodyPart.java:698) ~[javax.mail-1.6.2.jar:1.6.2]
        at com.scalix.index.message.IndexableMimeMessage.addContent(IndexableMimeMessage.java:313) ~[classes/:?]
        at com.scalix.index.message.IndexableMimeMessage.addContent(IndexableMimeMessage.java:331) ~[classes/:?]
        at com.scalix.index.message.IndexableMimeMessage.generateDocument(IndexableMimeMessage.java:104) ~[classes/:?]
        ... 31 more

Files

indexer.bad.boundary.eml indexer.bad.boundary.eml 2.91 KB Alexey Bobyr, 10/01/2018 09:37 AM

History

#1

Updated by Alexey Bobyr about 1 year ago

  • File deleted (indexer.bad.ical.eml)
#2

Updated by Alexey Bobyr about 1 year ago

Alexey Bobyr wrote:

[...]

#3

Updated by Alexey Bobyr about 1 year ago

  • Status changed from New to Rejected

malformed email. even Thunderbird can not parse it.

Also available in: Atom PDF