Project

General

Profile

Bug #61204

populateFirstMatchingPartData NullPointerException

Added by Alexey Bobyr about 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Alexey Bobyr
Category:
Scalix API
Target version:
Start date:
08/11/2018
Due date:
% Done:

0%

Estimated time:
Operation System:
--

Description

2018-08-09 11:50:42.175 [FATAL] [http-nio2-8080-exec-11] [ImapDataCache.ensureScalixDavBodyPopulated:418] Could not fetch scalix dav body data for 0024adfee61546f3
2018-08-09 11:50:42.176 [WARN ] [http-nio2-8080-exec-11] [RestServlet.sendError:34] Sending error
com.scalix.api.service.ServiceException: Could not fetch scalix dav body data
    at com.scalix.api.mailbox.ImapDataCache.ensureScalixDavBodyPopulated(ImapDataCache.java:442) ~[scalix-api.jar:1.0]
    at com.scalix.api.mailbox.ImapDataCache.getMessages(ImapDataCache.java:390) ~[scalix-api.jar:1.0]
    at com.scalix.api.mailbox.Mailbox.getMessages(Mailbox.java:349) ~[scalix-api.jar:1.0]
    at com.scalix.api.mailbox.SyncService.processMessageRefs(SyncService.java:217) ~[scalix-api.jar:1.0]
    at com.scalix.api.mailbox.SyncService.getMessageChanges(SyncService.java:198) ~[scalix-api.jar:1.0]
........
Caused by: java.lang.NullPointerException
    at com.scalix.api.imap.Imap.populateFirstMatchingPartData(Imap.java:1256) ~[scalix-api.jar:1.0]
    at com.scalix.api.imap.Imap.populateScalixDavBody(Imap.java:855) ~[scalix-api.jar:1.0]
    at com.scalix.api.mailbox.ImapDataCache.ensureScalixDavBodyPopulated(ImapDataCache.java:421) ~[scalix-api.jar:1.0]
    ... 46 more

History

#2

Updated by Alexey Bobyr about 1 year ago

  • Status changed from New to Rejected

Also available in: Atom PDF