Project

General

Profile

Feature #61110

Scalix Connector build info ( public builds )

Added by Alexey Bobyr over 1 year ago. Updated 3 months ago.

Status:
New
Priority:
Normal
Assignee:
OutlookMAPIClientDevsGroup
Category:
Outlook
Target version:
Start date:
02/26/2018
Due date:
% Done:

0%

Estimated time:
Operation System:
--

Description

build info for 12.7.0.9166_x86

search : fixed "no attachments", deleted duplicate UAL_LIST call
#61103 - as a workaround synchronized max amount of emails to fetch per request from 32k to 128k.

P.S. this thread MUST be update when new build of connector is available for testing or public review.


Files

Screenshot_20180823_103025.png View Screenshot_20180823_103025.png 58.1 KB Alexey Bobyr, 08/23/2018 03:32 AM
Screenshot_20190302_113836.png View Screenshot_20190302_113836.png 10.7 KB Alexey Bobyr, 03/02/2019 12:30 PM
Screenshot_20190310_104340.png View Screenshot_20190310_104340.png 23.3 KB Alexey Bobyr, 03/11/2019 09:13 AM
Screenshot_20190314_110243.png View Screenshot_20190314_110243.png 45.3 KB Alexey Bobyr, 03/15/2019 09:21 AM

History

#1

Updated by Alexey Bobyr over 1 year ago

Setup_12.7.0.9167_x86.exe

#60954 Error1008: MAPI initialization failed (sxmigrate fails to migrate messages)

#2

Updated by Alexey Bobyr over 1 year ago

Setup12.7.0.9168_x86

- fix decoding display name (sender) for senders name in non ASCII - https://rm.scalix.com/issues/61091
- https://rm.scalix.com/issues/60954
- https://rm.scalix.com/issues/60841

#3

Updated by Alexey Bobyr over 1 year ago

- Setup_12.7.0.9169_x86.exe
memory corruption fix

#4

Updated by Alexey Bobyr over 1 year ago

Setup_12.7.0.9170_x86.exe

#61104 Outlook doesn't not start (INT32 => INT16)

#5

Updated by Alexey Bobyr over 1 year ago

Setup_12.7.0.9071_x86.exe

MemMappedFile memory corruption (on copying empty string) + handling nullptr for sort criteria

(#61104)

#6

Updated by Alexey Bobyr over 1 year ago

Setup_12.7.0.9072_x86.exe

- Scalix Rules wizard - error popup after closing.
- minor memory exception fixes

#7

Updated by Rafael Peregrino da Silva over 1 year ago

I think the version number is wrong: it should be 9172 instead of 9072, shouldn't it?

Best!

Rafael

Alexey Bobyr wrote:

Setup_12.7.0.9072_x86.exe

- Scalix Rules wizard - error popup after closing.
- minor memory exception fixes

#8

Updated by Alexey Bobyr over 1 year ago

Setup_12.7.0.9173_x86.exe

1. emails shows in Reminder Dialog
2. duplicate folders creations (handle folder names in utf-8)

#9

Updated by Alexey Bobyr over 1 year ago

Setup12.7.0.9174_x86

1. #61152 - Outlook crashes when you try to cancel current search
2. CertAddr escape `=` in keys.

#10

Updated by Alexey Bobyr over 1 year ago

Setup_12.7.0.9175
1. fixes for search by Flags in OU. not everything works for now but ~50%
2. workaround for truncating of Creator to 200 symbols - for #61091 . not fully solved .

#11

Updated by Alexey Bobyr over 1 year ago

Setup_12.7.0.9176_x86.exe

1. Search by flags #61156 (related to #60362)
2. Search substrings . require
scalix-sis-12.7.1.26761-1.noarch

#12

Updated by Alexey Bobyr over 1 year ago

Setup_12.7.0.9177_x86.exe

#61172 the e-mail address is now written with "Chinese characters"

#13

Updated by Alexey Bobyr about 1 year ago

  • Status changed from New to Resolved
  • Target version changed from All to 12.7.1

it seems it works normally in Setup12.7.1.9178.
closing it.

#14

Updated by Alexey Bobyr about 1 year ago

  • Status changed from Resolved to New
  • Target version changed from 12.7.1 to All

Please ignore my previous comment(wrong ticket).

Setup12.7.1.9178
1. #60451 Tasks statuses mismatch between OL and SWA
2. #60784 Outlook has problems because of a not correct formatted email address in TO field
3. #60911 lower defaults of ExternalFileThreshold for MBC

#15

Updated by Alexey Bobyr about 1 year ago

Setup_12.7.1.9179_x86.exe

#60130 -unable to search for Contacts in Addressbook

#16

Updated by Alexey Bobyr about 1 year ago

Setup_12.7.1.9180_x86.exe

#60441 SmartCache status and Sync log pop-up doesn't appear on top of opened windows stack.
#60786 use alternative sender address

#17

Updated by Alexey Bobyr about 1 year ago

Setup_12.7.1.9181_x86.exe

enhancements #60441

#18

Updated by Alexey Bobyr about 1 year ago

Setup_12.7.1.9182_x86.exe
- #61190 - Outlook Rules Wizard opens (with DE lang) instead of Scalix Connector Rules Wizard

#19

Updated by Alexey Bobyr about 1 year ago

Setup_12.7.1.9183_x86.exe

#60635 - Add "Rules" Button to open directly from scalix Tab/Tooltip

#20

Updated by Alexey Bobyr about 1 year ago

  • Tracker changed from Support to Feature
#21

Updated by Alexey Bobyr about 1 year ago

Setup_12.7.1.9184_x86.exe

#61202 - Outlook crashed when opening tasks
#61202 - Identification installed language of scalix connect
- OpenSSL v 1.1.0h .

#22

Updated by Alexey Bobyr 12 months ago

Setup_12.7.1.9187_x86.exe

A changes to prevent Outlook crashes. Some performance fixes.

#23

Updated by Alexey Bobyr 12 months ago

@all

Build machine is compromised . Please do not install
Setup_12.7.1.9187_x86.exe

#25

Updated by Alexey Bobyr 12 months ago

Scalix Connect for Microsoft Outlook 12.7.1.9189 (x86) English.msi
Scalix Connect for Microsoft Outlook 12.7.1.9189 (x86) German DE.msi
Scalix Connect for Microsoft Outlook 12.7.1.9189 (x86) Italian IT_it.msi
Scalix Connect for Microsoft Outlook 12.7.1.9189 (x86) Portuguese Brazil.msi

at upcoming.

#26

Updated by Alexey Bobyr 12 months ago

Early public builds of Scalix Connector installer.

Scalix Connect for Microsoft Outlook 12.7.1.9190 (x86) English.msi
Scalix Connect for Microsoft Outlook 12.7.1.9190 (x86) Italian.msi
Scalix Connect for Microsoft Outlook 12.7.1.9190 (x86) German.msi
Scalix Connect for Microsoft Outlook 12.7.1.9190 (x86) Portuguese Brazil.msi

Since that version.
1. we are shipping only msi.
2. if scalix connector installed on target machine installer will remove previous version automatically.
3. attempt to install newer version of Scalix Connector will show installation dialog. So when you update Scalix Connector you wont see 'upgrade' option or similar , but it will remove previously installed version.
4. Before installing/upgrade following applications will be silently closed

Outlook.exe
SXCacheMgr.exe
sxservice.exe
SXWipe32.exe
sxualwsd32.exe

So if you had Outlook running and it was closed during installation process don't worry its ok. Well to update Scalix Connector files we do not need them running .

4. Running msi after successful installation will show Maintenance Welcome dialog where - Repair will repair installation, and Uninstall - will uninstall Scalix Connector . so no need to go to the 'Control Panel' -> Programs and... and Uninstall Scalix Connector from that place.

5. All installers localized (even msi for Italian will have Wizard in Italian).
6. Automatically installs Visual C++ Redistributable 2015 (v141). before was v140 .
7. After Uninstalling connector only Scalix folder will be left in Program Files. Before 'Program Files' contained
Scalix/Connector and some dlls if ScalixAutoUpdate was invoked. With this version Installer will remove Connector folder.

It seems that all changes .

Please do not install it to client machines, well installer was rewritten and its possible that something was not migrated. If you tried this installer and found something wrong please create rm entry , or contact to support or write to me (registered users should see my email in profile)

#27

Updated by Alexey Bobyr 12 months ago

'Scalix Connect for Microsoft Outlook 12.7.1.9191 (x86) English.msi'
'Scalix Connect for Microsoft Outlook 12.7.1.9191 (x86) Italian.msi'
'Scalix Connect for Microsoft Outlook 12.7.1.9191 (x86) German.msi'
'Scalix Connect for Microsoft Outlook 12.7.1.9191 (x86) Portuguese Brazil.msi'

1. Ensure that all actions invoked with Administrative rights.
2. MSI can be installed from Network Location , as far as I remember before it was needed to copy installer into local file system and run it.

In general it seems that current build safe to use.

#28

Updated by Alexey Bobyr 11 months ago

'Scalix Connect for Microsoft Outlook 12.7.1.9193 (x86) English.msi'
'Scalix Connect for Microsoft Outlook 12.7.1.9193 (x86) Italian.msi'
'Scalix Connect for Microsoft Outlook 12.7.1.9193 (x86) German.msi'
'Scalix Connect for Microsoft Outlook 12.7.1.9193 (x86) Portuguese Brazil.msi'

- fix profile creating .
- updated libiconv and zlib to latest versions.

#29

Updated by Alexey Bobyr 11 months ago

'Scalix Connect for Microsoft Outlook 12.7.1.9193 (x86) English.msi'
'Scalix Connect for Microsoft Outlook 12.7.1.9193 (x86) Italian.msi'
'Scalix Connect for Microsoft Outlook 12.7.1.9193 (x86) German.msi'
'Scalix Connect for Microsoft Outlook 12.7.1.9193 (x86) Portuguese Brazil.msi'

version the same but fixed not able to create new profile with scalix WIN 10 (fix in installer).

#30

Updated by Alexey Bobyr 11 months ago

For users who are using SmartCache with headers only.
Please do not install latest builds or switch to full SmartCache .
It seems there is an regression. Connector does not work with SmartCache with Headers only as should.

#31

Updated by Alexey Bobyr 9 months ago

You may see Scalix Connector version 12.8.0.9193 at upcoming folder, but it does not contains any changes.
Version was changed to be sync version with rest component versioning.

Version 12.7.1 wont release. 12.8 version should release by the end of next week.

#32

Updated by Alexey Bobyr 8 months ago

12.8.0.9196

- Installer fixes ensure that all files are updated during Update.
- #61241 fixes for WIN 10 & Office Home && Business 2016 (sending email)
- create profile fixes.
- #61236 After setup Outlook starts with an error message . (WIN 10)

Please first test it at some machine and only then install to users workstation.

#33

Updated by Alexey Bobyr 8 months ago

12.8.0.9197
small fixes

#34

Updated by Alexey Bobyr 8 months ago

12.8.0.9198

#61259 Profile name not removed from ProfileMap.ini
- Profile wizard bug fixes

#35

Updated by Alexey Bobyr 8 months ago

12.8.0.9199
- fix for SmartCache + headers only (smartcache headers only works)

#36

Updated by Alexey Bobyr 7 months ago

12.8.0.9200
small bugfixes

#37

Updated by Alexey Bobyr 7 months ago

12.8.0.9201
- search / sorting fix
- memory corruption during decoding email sender name
- memory corruption during processing properties.
- updated opensll library now everything is complied and runs with Visual C++ 2015 14.0 Runtime library . before opensll require msvcr120.dll

#38

Updated by Alexey Bobyr 7 months ago

12.8.0.9202
- fix decoding email subject.
- prevent some crashes.
- prevent infinitive loop for getting notifications from server.
- fixed parsing DirEntry (better x.400 attr parser)
- memory corruption fixes

#39

Updated by Alexey Bobyr 6 months ago

12.8.0.9203
- fix Searching for "All Outlook Items" with "Conversation" (not all cases covered)
- prevent crashes during processing notification for non existing item
- small fixes and enhancements

#40

Updated by Alexey Bobyr 6 months ago

12.8.0.9205

prevent some OU crashes (including during search)

#41

Updated by Alexey Bobyr 6 months ago

12.8.0.9210 x64 and x86

Scalix Connector x64 first public builds.

Please do not use it for production - consider that build as Beta and some issues have not discovered so far.
We performed only quick tests(profile without smart cache, profile with full smartcache , and profile with smartcache headers only) and it seems everything is working but who knows - everything is possible.

To participate in testing please download ZIP archive from upcoming folder (contact with scalix representetive if you does not where it)
At this stage there are no all in one installer, but will have when Scalix Connector x64 will be stable.
Scalix Connector x64 depends on Microsoft Access Database Engine 2016 Redistributable
you can download it here https://www.microsoft.com/en-us/download/details.aspx?id=54920 or take that in
archive.

So for now to try Scalix Connector x64 :
1. install Microsoft Outlook x64

2. then please download for e.g.

Scalix Connect for Microsoft Outlook 12.8.0.9210 (x64) English.zip

3. unpack and install first

AccessDatabaseEngine_X64.exe or download it (link above)

then

Scalix Connect for Microsoft Outlook 12.8.0.9210 (x64) English.msi

If you had Mail profiles created with Scalix Connector x86 12.8.0.9205 you will see this warning.

But its better to recreate Mail Profiles with Scalix provider.

Since Scalix Connector shares the same codebase with x86 arhitecture stable Scalix Connector x86 is 12.8.0.9205 in upcoming folder will be in folder 'stable_x86_connector'

There are no some special features in Scalix Connector x64 except that SmatyCache is using accdb file format (Access Database 2007 and higher).
So please do not report on missing mbcmailbox.mdb now its mbcmailbox.accdb.
MDB file format is old, modern accdb file format should fix some issues but lets see.

Also please note that we have not checked localized versions of Scalix Connector x64, they should work but at this moment we are trying to get
stable x64 itself and then will take a look into localized versions if there will be not translated parts (that was localized in x86).

If you have found an issue please feel free to create a ticket in rm.scalix.com and specify category 'Outlook x64' we will try to solve it.

#42

Updated by Alexey Bobyr 5 months ago

12.8.0.9215
minor fixes for x64 support, and performance fixes for X64 and x86.

SCalix Connector x64 installer changed from msi to exe. Scalix Connector x64 does not contain any dependencies(even old DAO driver ...), all dependencies installed by Scalix Connector ... .exe.

So if you want to use just MSI you should manually install/update Microsoft Visual C++ 2015 Update 3 RC and Microsoft Access Database engine 2016.

Scalix Connector exe installer will try to detect if Outlook x64 is installed

It seems that Bitness for Office application is stored here (in registry)

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Outlook

So for Outlook x86 registry key

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Outlook\Bitness

does not exists
and if Outlook x64
then registry key

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Outlook\Bitness

will have value "x64"

But not sure if its correct way.

X86 builds will be available later today . For now uploaded only x64

Scalix Connect for Microsoft Outlook 12.8.0.9215 (x64) English (en-us).exe
Scalix Connect for Microsoft Outlook 12.8.0.9215 (x64) English (en-us).msi 
Scalix Connect for Microsoft Outlook 12.8.0.9215 (x64) German (de-de).msi 
Scalix Connect for Microsoft Outlook 12.8.0.9215 (x64) German (de-de).exe 
Scalix Connect for Microsoft Outlook 12.8.0.9215 (x64) Portuguese Brazil (pt-br).msi
Scalix Connect for Microsoft Outlook 12.8.0.9215 (x64) Portuguese Brazil (pt-br).exe 
Scalix Connect for Microsoft Outlook 12.8.0.9215 (x64) Italian (it-it).exe          
Scalix Connect for Microsoft Outlook 12.8.0.9215 (x64) Italian (it-it).msi 

#43

Updated by Alexey Bobyr 5 months ago

uploaded

sxmigrate_32.exe (for x86 Connector)

and

sxmigrate.exe (for x64 Connector)

into upcoming folder.

#44

Updated by Alexey Bobyr 5 months ago

12.8.0.9217

-search fix for x64 - results for some filters did not appear when searching in profile with SmartCache.
-sxmigrate is part of Scalix Connector . you can find it in C:\ProgramFiles\Scalix\Connect\

#45

Updated by Alexey Bobyr 4 months ago

12.8.0.9219

#61290 - SmartCache profile not synced due error - 'the field is too small to accept amount of data you attempted to add'
#61295 - profile create wizard crashes on invalid host

#46

Updated by Alexey Bobyr 3 months ago

12.8.0.9220

not fully covers #61010, #60918 some emails in OU is blank.
- fix in HTML to RTF builder ignore & for script and style html tag. Without it generated RTF doc was invalid at least for OU.
- some emails specifies HTML part but its empty. Make default behavior as SWA/AS show text part. Please note that adding text/plain part for specific cases which maybe different for other emails.

Some emails may be not opened due that they have RTF_COMPRESSED (already have RTF document) and RTFSync should take that document and set as email body ,
but for unknown reasons OU can not display it - maybe OU does not like it or ...

builds will be available in 2 hours at upcoming(building x86 Connector).

Also available in: Atom PDF