Project

General

Profile

Bug #60908

unable to complete account configuration with "Nine Exchange ActiveSync Client"

Added by Dirk Ahrnke over 2 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Christoph Schmolmueller
Category:
Scalix Wireless
Target version:
Start date:
02/28/2017
Due date:
% Done:

0%

Estimated time:
Operation System:
Rhel 6

Description

Issue reported by customer, reproduced by me

Nine (http://www.9folders.com/) is an alternative EAS client for Android devices. This client worked fine for versions until 12.6.0 GA.
It appears that the changes introduced by #60039 now lead into problems to create new accounts.

During the setup an error appears on the device saying
"Fertigstellen nicht möglich. Dieses Gerät wurde vom Server aus ferngesteuert gelöscht. Um es mit dem Server zu synchronisieren, muss es aus der Liste am Server entfernt werden. Bitte dazu den Server-Administrator kontaktieren"

short translation: device was wiped and has to be removed from the list on the server.

The error happens independently from all combinations of wireless.provisioning and wireless.provisioning.allowPartial


Files

Screenshot_20170228_170713.png View Screenshot_20170228_170713.png 34 KB Alexey Bobyr, 02/28/2017 10:16 AM
scalix-wireless.jar scalix-wireless.jar 396 KB Alexey Bobyr, 02/28/2017 11:34 AM
logs_nine.zip logs_nine.zip 1.28 MB Prakash Nikhar, 04/06/2017 09:43 AM

History

#1

Updated by Dirk Ahrnke over 2 years ago

Snippet from Apache-Log

xx.xx.xx.xx - - [28/Feb/2017:15:30:20 +0100] "OPTIONS /Microsoft-Server-ActiveSync HTTP/1.1" 200 - "-" "Nine-serranoltexx/KOT49H" 
xx.xx.xx.xx - - [28/Feb/2017:15:30:23 +0100] "POST /Microsoft-Server-ActiveSync?Cmd=Provision&User=john.doe%40s.domain.tld&DeviceId=NineA7038A0479B5&DeviceType=Android HTTP/1.1" 200 13 "-" "Nine-serranoltexx/KOT49H"

wireless.properties set in this case set to default:

wireless.provisioning=false
# Allow clients to partially implement the policy (at least the PIN was enabled)
wireless.provisioning.allowPartial=true

the log on the client states that the server supports provisioning and fails with "Null provisioning policy"

SDK Version : 19
Release Version : 4.4.2
Device Build : [Model: GT-I9195, Product: serranoltexx, Brand: samsung, Manufacturer: samsung, MSM8960, I9195XXUCOI4, serranolte, KOT49H.I9195XXUCOI4, samsung/serranoltexx/serranolte:4.4.2/KOT49H/I9195XXUCOI4:user/release-keys, I9195XXUCOI4, qcom, SWHD7520, KOT49H,release-keys, 1442989861000, user, dpi]
Application Version : 3.2.2c (1302230)
Security Model : Device
DeviceId : NineA7038A0479B5
Rooting : Not Rooted
Apk location : /data/app/com.ninefolders.hd3-1.apk
Install location : 0[auto]
Encryption: [System: true, Data: false]
Store : GooglePlay [false, true, false]
===============================================================================
===============================================================================
02-28 15:30:00.496|I|Exchange|-1|validate() result: 65621 [0x00010055]
02-28 15:30:00.494|W|Exchange|-1|plain text query in Request line ? false
02-28 15:30:00.493|I|Exchange|-1|Denied access by server provision: 3
02-28 15:30:00.493|W|Exchange|-1|Provision check status: 3
02-28 15:30:00.493|E|ProvisionJob|-1|Exception occurred in Provision.
com.ninefolders.hd3.engine.protocol.EASResponseException: Null Provision policy.
    at com.ninefolders.hd3.engine.job.ak.a(ProGuard:438)
    at com.ninefolders.hd3.engine.c.aa.b(ProGuard:653)
    at com.ninefolders.hd3.engine.c.aa.a(ProGuard:400)
    at com.ninefolders.hd3.engine.c.aa.n(ProGuard:308)
    at com.ninefolders.hd3.engine.service.ai.a(ProGuard:513)
    at com.ninefolders.hd3.emailcommon.service.bc.onTransact(ProGuard:55)
    at android.os.Binder.execTransact(Binder.java:404)
    at dalvik.system.NativeStart.run(Native Method)

02-28 15:29:59.524|I|ProvisionJob|-1|provision: john.doe@s.domain.tld/s.domain.tld
02-28 15:29:59.523|I|Exchange|-1|Provision command supported by server
02-28 15:29:59.501|I|Exchange|-1|Protocol version:12.0, AccountId:-1
02-28 15:29:59.500|I|Exchange|-1|doOptions() response:0
02-28 15:29:59.496|D|JobOption|-1|====================
02-28 15:29:59.496|D|JobOption|-1|X-Nine-Response-Source: HTTP/1.1 200 OK
02-28 15:29:59.495|D|JobOption|-1|X-Android-Sent-Millis: 1488292196962
02-28 15:29:59.495|D|JobOption|-1|X-Android-Selected-Transport: http/1.1
02-28 15:29:59.495|D|JobOption|-1|X-Android-Response-Source: NETWORK 200
02-28 15:29:59.493|D|JobOption|-1|X-Android-Received-Millis: 1488292199457
02-28 15:29:59.493|D|JobOption|-1|Public: OPTIONS, POST
02-28 15:29:59.493|D|JobOption|-1|MS-Server-ActiveSync: 8.0
02-28 15:29:59.493|D|JobOption|-1|MS-ASProtocolVersions: 2.5,12.0
02-28 15:29:59.493|D|JobOption|-1|MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,FolderSync,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,Search,Ping,Provision,ItemOperations,Settings
02-28 15:29:59.493|D|JobOption|-1|Date: Tue, 28 Feb 2017 14:30:20 GMT
02-28 15:29:59.492|D|JobOption|-1|Content-Type: text/plain; charset=UTF-8
02-28 15:29:59.485|D|JobOption|-1|Content-Length: 0
02-28 15:29:59.484|D|JobOption|-1|Connection: close
02-28 15:29:59.484|D|JobOption|-1|Cache-Control: no-cache, no-store, max-age=0, must-revalidate, proxy-revalidate, no-transform
02-28 15:29:59.484|D|JobOption|-1|Allow: OPTIONS, POST
02-28 15:29:59.484|D|JobOption|-1|== OPTIONS RESULT ==
02-28 15:29:56.676|I|Exchange|-1|validate(): s.domain.tld, null, john.doe@s.domain.tld, null, 443, 13, Nine-serranoltexx/KOT49H, , null
02-28 15:29:56.676|D|SyncEngineService|-1|IEmailService.validate
#2

Updated by Dirk Ahrnke over 2 years ago

  • Assignee changed from Dirk Ahrnke to Alexey Bobyr

@Alexey: can you please have a look and give a statement where the specifiation is not correctly implemented (client or server)?

#3

Updated by Alexey Bobyr over 2 years ago

It appears that the changes introduced by #60039 now lead into problems to create new accounts.

those changes was in 12.5.x version.
in 12.6.0 I added provisioning configurable items into config and set them as default.

and it seems that the behavior the same as with Outlook for Android.
after app upgrade (android) it stopped work.

see screenshot it seems that they using 16 version of EAS .

but we support only 12.1 and client must use our(server) version - need to review docs but its as far as I remember.

Also we do not support 3rd party EAS clients they may work or not.
if need support for this client please raise Future request approved by csm or pascal ....

I have checked [MS-ASHTTP].pdf . and did not found any Provisioning header item. maybe need to check the rest docs
if this client expect it. if it documentation maybe I would help .
for now I does not have any clue why it does not work.

If you have installed 12.5 somewhere and this client you can try - the result can be the same as for 12.6.0 - it wont work.

Anyway I will check docs maybe small thing is missing but for full support would be need time - since it was not ever tested with this app.

Dirk Ahrnke wrote:

Issue reported by customer, reproduced by me

Nine (http://www.9folders.com/) is an alternative EAS client for Android devices. This client worked fine for versions until 12.6.0 GA.
It appears that the changes introduced by #60039 now lead into problems to create new accounts.

During the setup an error appears on the device saying
"Fertigstellen nicht möglich. Dieses Gerät wurde vom Server aus ferngesteuert gelöscht. Um es mit dem Server zu synchronisieren, muss es aus der Liste am Server entfernt werden. Bitte dazu den Server-Administrator kontaktieren"

short translation: device was wiped and has to be removed from the list on the server.

The error happens independently from all combinations of wireless.provisioning and wireless.provisioning.allowPartial

#4

Updated by Alexey Bobyr over 2 years ago

sorry forgot to attach screenshot

#5

Updated by Alexey Bobyr over 2 years ago

can you please try to enable provisioning maybe it would help

#6

Updated by Dirk Ahrnke over 2 years ago

Alexey Bobyr wrote:

can you please try to enable provisioning maybe it would help

I tried with wireless.provisioning=true as well (in addition) with wireless.provisioning.allowPartial=false with the same results

#7

Updated by Alexey Bobyr over 2 years ago

  • File Screenshot_20170228_172202.png added
#10

Updated by Alexey Bobyr over 2 years ago

#12

Updated by Alexey Bobyr over 2 years ago

  • File deleted (Screenshot_20170228_172202.png)
#13

Updated by Alexey Bobyr over 2 years ago

Do you restart scalix-tomcat service when you change wireless.provisioning?
web applications loads settings at start up and does not checks file settings for changes.

Dirk Ahrnke wrote:

Alexey Bobyr wrote:

can you please try to enable provisioning maybe it would help

I tried with wireless.provisioning=true as well (in addition) with wireless.provisioning.allowPartial=false with the same results

#14

Updated by Dirk Ahrnke over 2 years ago

Alexey Bobyr wrote:

Do you restart scalix-tomcat service when you change wireless.provisioning?

Yes, of course. "touch"ing WEB-INF of wireless should work too, but I am usually too lazy to search its directory.

#18

Updated by Dirk Ahrnke over 2 years ago

  • Assignee changed from Alexey Bobyr to Christoph Schmolmueller

it should be decided by product management if the Nine-Client is supported.

#19

Updated by Prakash Nikhar over 2 years ago

Hi,

I Just performed a test to configure AS on Nine Version 3.2.4 (1302400) 13 Days trial version, it seems working fine for me on Samsung Android 6.0.1,

192.168.43.101 - - [06/Apr/2017:18:55:29 +0530] "POST /Microsoft-Server-ActiveSync?Cmd=Ping&User=astest2%40rhel72test.com&DeviceId=Nine381CD5C8E3CF&DeviceType=Android HTTP/1.1" 200 13 "-" "Nine-on7xelteins/MMB29K" 
192.168.43.101 - - [06/Apr/2017:19:09:48 +0530] "POST /Microsoft-Server-ActiveSync?Cmd=Ping&User=astest2%40rhel72test.com&DeviceId=Nine381CD5C8E3CF&DeviceType=Android HTTP/1.1" 200 13 "-" "Nine-on7xelteins/MMB29K" 
[root@sx1261 ~]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.2 (Maipo)
[root@sx1261 ~]# rpm -qa | grep scalix
scalix-chardet-1.0.20071031-2.rhel7.i686
scalix-res-12.6.1.14746-1.noarch
scalix-wireless-12.6.1.17846-1.noarch
scalix-text-extractors-1.0-3.rhel7.i686
scalix-tomcat-7.0.75-53.noarch
scalix-libical-0.44.976-2.rhel7.i686
scalix-platform-12.6.1.17700-1.noarch
scalix-swa-12.6.1.17750-1.noarch
scalix-sis-12.6.1.16117-1.noarch
scalix-tomcat-connector-12.6.0-14721.rhel7.noarch
scalix-iconv-extras-1.2-6.rhel7.i686
scalix-server-12.6.0.14933-1.rhel7.x86_64
scalix-sac-12.6.1.14746-1.noarch
scalix-postgres-12.6.0-15981.noarch

Please see the attached the logs

#20

Updated by Alexey Bobyr about 1 year ago

  • Status changed from New to Resolved
  • Target version set to 12.7.1

Nine client was working with 12.7.1 even task sync.

Also available in: Atom PDF