Project

General

Profile

Feature #60561

add "reload" button

Added by Andrea Lanfranchi over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Alexey Bobyr
Category:
Scalix Webmail (SWA)
Target version:
Start date:
07/06/2016
Due date:
% Done:

0%

Estimated time:
Operation System:
--

Description

In SWA it would be highly appreciated to have some "Reload" button available to accomplish these tasks:

  1. Refresh tree view in left pane (some folders may have been created or modified outside SWA : eg. OL or IMAP or ActiveSync)
  2. Refresh folder content

At present the only option to refresh contents and or folder tree is to logout and login again.


Files

send_receive.png View send_receive.png 64.5 KB Alexey Bobyr, 07/06/2016 05:20 AM
refresh_btn2.png View refresh_btn2.png 8.63 KB Alexey Bobyr, 07/20/2016 07:25 AM
refresh_btn.png View refresh_btn.png 12.1 KB Alexey Bobyr, 07/20/2016 07:25 AM
OVA Exch2010.JPG View OVA Exch2010.JPG 111 KB OWA Check Messages (Refrech button) Christian Schwirtz, 07/25/2016 07:08 AM
reload_bth.png View reload_bth.png 4.7 KB Alexey Bobyr, 08/17/2016 05:08 AM
classic_theme.png View classic_theme.png 8.44 KB Alexey Bobyr, 09/30/2016 06:28 AM
defaul_theme.png View defaul_theme.png 8.82 KB Alexey Bobyr, 09/30/2016 06:28 AM

History

#1

Updated by Alexey Bobyr over 3 years ago

menu Tools > Send and receive ->
Send and receive All - will refresh folder tree and messages in folders and send all pending emails in Outbox folder
- Receive All- will refresh folder tree and messages in folders
- Send All - send all pending emails in Outbox folder

I can put Receive All into toolbar after dropdown menu (compose new message,....).

Andrea Lanfranchi wrote:

In SWA it would be highly appreciated to have some "Reload" button available to accomplish these tasks:

  1. Refresh tree view in left pane (some folders may have been created or modified outside SWA : eg. OL or IMAP or ActiveSync)
  2. Refresh folder content

At present the only option to refresh contents and or folder tree is to logout and login again.

#2

Updated by Andrea Lanfranchi over 3 years ago

Never noticed that and it's quite counterintuitive. In OL Send-And-Receive is only related to pending messages to be sent or to be received.
Also ... does the send and receive also reloads contents of NON-MAIL folders (eg. contacts, tasks, calendar) ?

What would be the burden to have a proper reload button (like in SAC) and have Send-And-Receive to behave like the same function in OL ?

#3

Updated by Alexey Bobyr over 3 years ago

I can tell that it must applies to all folders.
So in general if you click at least at 'Receive All' the first what will be done its refresh folder tree (new, deleted, ....)
and than it should update folder stats (number of msgs, new msgs etc) and will update user interface if there were some changes . I can check it if it so.
For now I can tell that it must reload content of subscribed folders and currently opened folder (selected in tree view).

I can create reload button like SAC has but I need to know in what place of webmail interface put this 'refresh' button

Sorry I don't know OL interface.

Andrea Lanfranchi wrote:

Never noticed that and it's quite counterintuitive. In OL Send-And-Receive is only related to pending messages to be sent or to be received.
Also ... does the send and receive also reloads contents of NON-MAIL folders (eg. contacts, tasks, calendar) ?

What would be the burden to have a proper reload button (like in SAC) and have Send-And-Receive to behave like the same function in OL ?

#4

Updated by Alexey Bobyr about 3 years ago

Quick implementation of reload button. in scalix-swa-12.6.0.17706-1.noarch.rpm
see attachments how it looks.

Please let me now if its ok to add into 12.6.

Alexey Bobyr wrote:

I can tell that it must applies to all folders.
So in general if you click at least at 'Receive All' the first what will be done its refresh folder tree (new, deleted, ....)
and than it should update folder stats (number of msgs, new msgs etc) and will update user interface if there were some changes . I can check it if it so.
For now I can tell that it must reload content of subscribed folders and currently opened folder (selected in tree view).

I can create reload button like SAC has but I need to know in what place of webmail interface put this 'refresh' button

Sorry I don't know OL interface.

Andrea Lanfranchi wrote:

Never noticed that and it's quite counterintuitive. In OL Send-And-Receive is only related to pending messages to be sent or to be received.
Also ... does the send and receive also reloads contents of NON-MAIL folders (eg. contacts, tasks, calendar) ?

What would be the burden to have a proper reload button (like in SAC) and have Send-And-Receive to behave like the same function in OL ?

#5

Updated by Alexey Bobyr about 3 years ago

refresh icon is from SAC.

Alexey Bobyr wrote:

Quick implementation of reload button. in scalix-swa-12.6.0.17706-1.noarch.rpm
see attachments how it looks.

Please let me now if its ok to add into 12.6.

Alexey Bobyr wrote:

I can tell that it must applies to all folders.
So in general if you click at least at 'Receive All' the first what will be done its refresh folder tree (new, deleted, ....)
and than it should update folder stats (number of msgs, new msgs etc) and will update user interface if there were some changes . I can check it if it so.
For now I can tell that it must reload content of subscribed folders and currently opened folder (selected in tree view).

I can create reload button like SAC has but I need to know in what place of webmail interface put this 'refresh' button

Sorry I don't know OL interface.

Andrea Lanfranchi wrote:

Never noticed that and it's quite counterintuitive. In OL Send-And-Receive is only related to pending messages to be sent or to be received.
Also ... does the send and receive also reloads contents of NON-MAIL folders (eg. contacts, tasks, calendar) ?

What would be the burden to have a proper reload button (like in SAC) and have Send-And-Receive to behave like the same function in OL ?

#6

Updated by Christian Schwirtz about 3 years ago

looklike OWA 2010

Andrea Lanfranchi wrote:

In SWA it would be highly appreciated to have some "Reload" button available to accomplish these tasks:

  1. Refresh tree view in left pane (some folders may have been created or modified outside SWA : eg. OL or IMAP or ActiveSync)
  2. Refresh folder content

At present the only option to refresh contents and or folder tree is to logout and login again.

#7

Updated by Alexey Bobyr about 3 years ago

change icon and move it to the right side?

Christian Schwirtz wrote:

looklike OWA 2010

Andrea Lanfranchi wrote:

In SWA it would be highly appreciated to have some "Reload" button available to accomplish these tasks:

  1. Refresh tree view in left pane (some folders may have been created or modified outside SWA : eg. OL or IMAP or ActiveSync)
  2. Refresh folder content

At present the only option to refresh contents and or folder tree is to logout and login again.

#8

Updated by Christian Schwirtz about 3 years ago

Alexey Bobyr wrote:

change icon and move it to the right side?

I only want you to now, where is it in OWA2010.
My personal opion is, to add it down to TM Scalix logo on the right sight.

Christian Schwirtz wrote:

looklike OWA 2010

Andrea Lanfranchi wrote:

In SWA it would be highly appreciated to have some "Reload" button available to accomplish these tasks:

  1. Refresh tree view in left pane (some folders may have been created or modified outside SWA : eg. OL or IMAP or ActiveSync)
  2. Refresh folder content

At present the only option to refresh contents and or folder tree is to logout and login again.

#9

Updated by Alexey Bobyr about 3 years ago

Yes I understood.
that's why I have asked approval from Christoph Schmolmueller or Pascal Lauria because in general it can placed anywhere.
the question is where the best place for our interface? I don't know.

Christian Schwirtz wrote:

Alexey Bobyr wrote:

change icon and move it to the right side?

I only want you to now, where is it in OWA2010.
My personal opion is, to add it down to TM Scalix logo on the right sight.

Christian Schwirtz wrote:

looklike OWA 2010

Andrea Lanfranchi wrote:

In SWA it would be highly appreciated to have some "Reload" button available to accomplish these tasks:

  1. Refresh tree view in left pane (some folders may have been created or modified outside SWA : eg. OL or IMAP or ActiveSync)
  2. Refresh folder content

At present the only option to refresh contents and or folder tree is to logout and login again.

#10

Updated by Alexey Bobyr about 3 years ago

  • Assignee changed from Alexey Bobyr to Monika Pum

Reassigning it to PM.
I have received comments that 'reload' button is old-style and that we maybe don't need it.
@Monika please work on it and let me know do I need implement(maybe with some changes) it or not.

Alexey Bobyr wrote:

Yes I understood.
that's why I have asked approval from Christoph Schmolmueller or Pascal Lauria because in general it can placed anywhere.
the question is where the best place for our interface? I don't know.

Christian Schwirtz wrote:

Alexey Bobyr wrote:

change icon and move it to the right side?

I only want you to now, where is it in OWA2010.
My personal opion is, to add it down to TM Scalix logo on the right sight.

Christian Schwirtz wrote:

looklike OWA 2010

Andrea Lanfranchi wrote:

In SWA it would be highly appreciated to have some "Reload" button available to accomplish these tasks:

  1. Refresh tree view in left pane (some folders may have been created or modified outside SWA : eg. OL or IMAP or ActiveSync)
  2. Refresh folder content

At present the only option to refresh contents and or folder tree is to logout and login again.

#11

Updated by Andrea Lanfranchi about 3 years ago

It may be old style but either we endorse some sort of continuos polling to check if something changed in tree structure (and of course apply changes accordingly) or the only option remains to logout and login again.

#12

Updated by Christian Schwirtz about 3 years ago

Hi Monika,

please come back to Alxey.
At the moment, the refresh button is not in 12.6

Many Thx,
Christian + Pascal + Andrea

Alexey Bobyr wrote:

Reassigning it to PM.
I have received comments that 'reload' button is old-style and that we maybe don't need it.
@Monika please work on it and let me know do I need implement(maybe with some changes) it or not.

Alexey Bobyr wrote:

Yes I understood.
that's why I have asked approval from Christoph Schmolmueller or Pascal Lauria because in general it can placed anywhere.
the question is where the best place for our interface? I don't know.

Christian Schwirtz wrote:

Alexey Bobyr wrote:

change icon and move it to the right side?

I only want you to now, where is it in OWA2010.
My personal opion is, to add it down to TM Scalix logo on the right sight.

Christian Schwirtz wrote:

looklike OWA 2010

Andrea Lanfranchi wrote:

In SWA it would be highly appreciated to have some "Reload" button available to accomplish these tasks:

  1. Refresh tree view in left pane (some folders may have been created or modified outside SWA : eg. OL or IMAP or ActiveSync)
  2. Refresh folder content

At present the only option to refresh contents and or folder tree is to logout and login again.

#13

Updated by Christoph Schmolmueller about 3 years ago

well, actually we had a email discussion and I agreed to put the button in for now. but yes the main fix is that the tree updates periodically (seems that is not the case right now) but I guess to implement pooling in the tree will take quite a lot longer than putting the button in.

#14

Updated by Alexey Bobyr about 3 years ago

I have just noticed that SWA interface has already such button (well for inbox folder and functionality is from menu Tools > Send and receive -> )
see my attach.
So we can replace that toolbar item and set proper image and ensure that it exists in all view's at SWA

#15

Updated by Christian Schwirtz about 3 years ago

To be honest, I would add a second reloaded button down to TM Scalix logo on the right sight for SWA dummies like me, if that need not much time to program.

Alexey Bobyr wrote:

I have just noticed that SWA interface has already such button (well for inbox folder and functionality is from menu Tools > Send and receive -> )
see my attach.
So we can replace that toolbar item and set proper image and ensure that it exists in all view's at SWA

#16

Updated by Alex I about 3 years ago

i'm confused.
now we have icon "send/receive" at toolbar for all folders, except calendars and contacts.
we can do only one thing: add green "refresh" icon at toolbar for calendars and contacts, and task can be closed.
Christoph pls. approve/comment ?

#17

Updated by Andrea Lanfranchi about 3 years ago

Well ... "Send and receive" has a linguistic meaning quite different from "Refresh".
This said it appears that "Send and receive" does not a proper refresh button.
Please try this (I am working on server mail.scalix.com) :

  • Open an Outlook session
  • Simultaneously open a webmail session for the same account
  • Using Outlook create a new top level folder (of type mail) named "Test Folder 1". Let Smartcache sync.
  • Switch to SWA, select Inbox folder and hit "Send and Receive" button. New folder "Test Folder 1" appears in the left tree.
  • Switch back to Outlook and right click on the newly created folder and hit "Delete". It will be moved to the Deleted Items folder. Let smartcache sync
  • Switch again to SWA and hit "Send and Receive" button. If not already so the deleted "Test Folder 1" will be depicted in left tree under the deleted items folder.
  • Again on Outlook and Empty the Recycle Bin (Deleted Items folder). Let smartcache sync.
  • Go back to SWA and hit "Send and Receive" button. No matter how many times you click or how much time you wait ... "Test Folder 1" remains there under the "Deleted Items" folder.
  • Try to click on the "Test Folder 1" and SWA prompts with an alert : "Error detected while trying to collect meta-data for folder "Test Folder 1"
At this stage you only have two options to have the left tree consistent:
  1. either you right click the "Deleted Items" folder and hit "Empty Folder" (but in this case SWA prompts with an alert "There was a problem deleting folder [Deleted Items/Test Folder 1]" ... you bet my friend it was already deleted !!!)
  2. or you reload the entire SWA page
  3. or, again, you logout from SWA and re-login

This behavior is confirmed even with "AutoRefresh" switch ticked on folders.

I am still convinced a very basic Refresh button (like in SAC) is needed.

#18

Updated by Christoph Schmolmueller about 3 years ago

and I agree with Andrea, we need to add it - please proceed

thanks

#19

Updated by Alex I about 3 years ago

let's clarify again
from description above we can consider "send/receive all" button as "refresh everything", but button image and text doesn't explain that properly. So, proposition is: duplicate this button, but with different image and label "Refresh". Button will appear at the right side after the last button on toolbar, since it's not easy to put it in arbitrary place.

Pls. let me know your thoughts

#20

Updated by Andrea Lanfranchi about 3 years ago

According to my note 17 there is still a problem with "Send and Receive" as it does not sync the folder tree under "Deleted Items" folder.
If you can manage to amend this it's ok for me to have a button named "Refresh" which actually behaves like send and receive.
Location proposed is ok.

#21

Updated by Alex I about 3 years ago

Bryan, please provide us with nice refresh icon (green color)

#22

Updated by Alexey Bobyr about 3 years ago

in scalix-swa-12.6.0.17720 . will be available soon at upcoming . please review .
if everything is ok - let me know or close this issue.

Alex Izhevsky wrote:

Bryan, please provide us with nice refresh icon (green color)

#23

Updated by Alexey Bobyr about 3 years ago

  • Status changed from Feedback to Closed
#24

Updated by Alex I almost 3 years ago

  • Subject changed from Scalix 12.6 SWA - Reload Button ? to add "reload" button

Also available in: Atom PDF