Project

General

Profile

Bug #60520

IO operation was interrupted while appending contact

Added by Alexey Bobyr over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Alexey Bobyr
Category:
Scalix Wireless
Target version:
Start date:
06/23/2016
Due date:
06/24/2016
% Done:

100%

Estimated time:
Operation System:
--

Description

./scalix-api.log

2016-06-23 04:06:22,799  WARN [PlatformDispatcherServlet.service:47] Problem processing request method=POST URI=/api/sxadmin-test@allwebsuite.com/mailbox/Contacts
org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.NullPointerException
        at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:980)
        at org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:870)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:650)
        at org.springframework.web.servlet.FrameworkServlet.service(FrameworkServlet.java:844)
        at com.scalix.api.PlatformDispatcherServlet.service(PlatformDispatcherServlet.java:43)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:731)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.springframework.web.filter.AbstractRequestLoggingFilter.doFilterInternal(AbstractRequestLoggingFilter.java:220)
        at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:107)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:218)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:169)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
        at org.apache.catalina.valves.StuckThreadDetectionValve.invoke(StuckThreadDetectionValve.java:220)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:442)
        at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1082)
        at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:623)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1756)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1715)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException
        at javax.mail.internet.MimeUtility.checkAscii(MimeUtility.java:1329)
        at javax.mail.internet.MimeUtility.encodeWord(MimeUtility.java:636)
        at javax.mail.internet.MimeUtility.encodeText(MimeUtility.java:444)
        at javax.mail.internet.MimeMessage.setSubject(MimeMessage.java:793)
        at javax.mail.internet.MimeMessage.setSubject(MimeMessage.java:757)
        at com.scalix.api.entity.Contact.toMimeMessage(Contact.java:54)
        at com.scalix.api.imap.Imap.appendMessage(Imap.java:1836)
        at com.scalix.api.mailbox.Mailbox.addMessageToFolder(Mailbox.java:972)
        at com.scalix.api.rest.MailboxServlet.doPost(MailboxServlet.java:578)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:650)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:731)
        at org.springframework.web.servlet.mvc.ServletWrappingController.handleRequestInternal(ServletWrappingController.java:158)
        at org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:147)
        at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:50)
        at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:959)
        at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:893)
        at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:968)
        ... 26 more

wireless log

2016-06-23 04:06:22,814 FATAL [PlatformClient.appendContact:1269] CLIENT - IO operation was interrupted while appending a calendar
com.scalix.wireless.api.service.PlatformException
        at com.scalix.wireless.api.service.Connection.execute(Connection.java:160)
        at com.scalix.wireless.api.service.PlatformClient.appendContact(PlatformClient.java:1261)
        at com.scalix.wireless.controller.command.SyncCommand.doAdditions(SyncCommand.java:759)
        at com.scalix.wireless.controller.command.SyncCommand.execute(SyncCommand.java:105)
        at com.scalix.wireless.handlers.WirelessRequestImpl.execute(WirelessRequestImpl.java:228)
        at com.scalix.wireless.HttpRequestHandler.handleRequest(HttpRequestHandler.java:136)
        at com.scalix.wireless.WirelessServlet.doPost(WirelessServlet.java:106)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:650)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:731)
        at org.springframework.web.servlet.mvc.ServletWrappingController.handleRequestInternal(ServletWrappingController.java:158)
        at org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:147)
        at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:50)
        at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:959)
        at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:893)
        at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:968)
        at org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:870)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:650)
        at org.springframework.web.servlet.FrameworkServlet.service(FrameworkServlet.java:844)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:731)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.springframework.web.filter.AbstractRequestLoggingFilter.doFilterInternal(AbstractRequestLoggingFilter.java:220)
        at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:107)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:218)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:169)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
        at org.apache.catalina.valves.StuckThreadDetectionValve.invoke(StuckThreadDetectionValve.java:220)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:442)
        at org.apache.coyote.ajp.AjpNioProcessor.process(AjpNioProcessor.java:175)
        at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:623)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1756)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1715)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
        at java.lang.Thread.run(Unknown Source)
2016-06-23 04:06:22,816  WARN [SyncCommand.doAdditions:788] COMMAND - deviceId: android1466668125473, user: sxadmin  - failed to create mime message encoding for added item.
org.apache.commons.httpclient.HttpException
        at com.scalix.wireless.api.service.PlatformClient.appendContact(PlatformClient.java:1270)
        at com.scalix.wireless.controller.command.SyncCommand.doAdditions(SyncCommand.java:759)
        at com.scalix.wireless.controller.command.SyncCommand.execute(SyncCommand.java:105)
        at com.scalix.wireless.handlers.WirelessRequestImpl.execute(WirelessRequestImpl.java:228)
        at com.scalix.wireless.HttpRequestHandler.handleRequest(HttpRequestHandler.java:136)
        at com.scalix.wireless.WirelessServlet.doPost(WirelessServlet.java:106)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:650)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:731)
        at org.springframework.web.servlet.mvc.ServletWrappingController.handleRequestInternal(ServletWrappingController.java:158)


Files

History

#1

Updated by Alexey Bobyr over 3 years ago

  • Due date set to 06/24/2016
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

In AS request FileAs was missing so subject (for saveing we needed it because its email ...)
if there are no FileAS in add contact request trying to determine best provided field for a subject

fix in 12.6.15587

Alexey Bobyr wrote:

./scalix-api.log

[...]

wireless log

[...]

Also available in: Atom PDF