Project

General

Profile

Bug #60510

SWA 12.6 : search on Calendar type folders does not find anything (but it should !!)

Added by Andrea Lanfranchi over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
WebDevsGroup
Category:
Scalix Webmail (SWA)
Target version:
Start date:
06/18/2016
Due date:
06/21/2016
% Done:

100%

Estimated time:
(Total: 0.00 h)
Operation System:
--

Description

Scalix Web Access
Version 12.6.0.17687
Platform Version 12.6.0.15494
Server Version 12.6.0.14885

Hitting search on a Calendar Folder which do have items, search returns no results. (See attached image swa-error-007.png)
Refining the search entering a text criteria search results reports "undefined" (See attached image 2)


Files

swa-error-007.png View swa-error-007.png 73.8 KB Andrea Lanfranchi, 06/18/2016 12:28 PM
swa-error-008.png View swa-error-008.png 17.2 KB Andrea Lanfranchi, 06/18/2016 12:30 PM
swa-error-015.png View swa-error-015.png 94.6 KB Andrea Lanfranchi, 06/20/2016 10:24 AM

Subtasks

Bug #60509: SWA : search on Calendar type folders starts with immediate search even if no criteria insertedResolvedWebDevsGroup

Actions

History

#1

Updated by Alexey Bobyr over 3 years ago

  • Tracker changed from Support to Bug
#2

Updated by Alexey Bobyr over 3 years ago

  • Status changed from New to Updated

Hitting search on a Calendar Folder which do have items, search returns no results

initial search was invalid - no search term specified . etc etc.
Now when search dialog opens it does not start search first you must set some search criteria - search value, importance or date range etc. fixes #60509

reviewed search filters made some changes now it must work

Refining the search entering a text criteria search results reports "undefined" (See attached image 2)

can be reproduced on prod server but not in test server. On production server for user enabled remote logging but even with them I could not understood why it happen.

I will try play with that but for now I could not reproduce locally maybe because I have a newer version .

Leaving for now this issue as opened . I will notify when I finish reviewing Search dialog and than close it with a reference to version when it fixed.

Andrea Lanfranchi wrote:

Scalix Web Access
Version 12.6.0.17687
Platform Version 12.6.0.15494
Server Version 12.6.0.14885

Hitting search on a Calendar Folder which do have items, search returns no results. (See attached image swa-error-007.png)
Refining the search entering a text criteria search results reports "undefined" (See attached image 2)

#3

Updated by Andrea Lanfranchi over 3 years ago

When search dialog appears a search starts ! This is ineludible.
Analyzing call requests with Fiddler I can see SWA to send this request:

<?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/1999/XMLSchema" xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Header><credentials xmlns="http://scalix.com/schemas/gofish" SOAP-ENV:mustUnderstand="1"><username>sxadmin</username><fugu>Ox7c714e5b603234342e24292825232f2c28342206</fugu><ts>1466431508</ts></credentials></SOAP-ENV:Header><SOAP-ENV:Body><m:search xmlns:m="http://scalix.com/methods"><query>(subject:IS NULL OR BODY:IS NULL OR location:IS NULL OR from:IS NULL OR to:IS NULL OR cc:IS NULL OR bcc:IS NULL) AND (x-scalix-class:IPM.Schedule.Meeting.Request OR x-scalix-class:IPM.Appointment OR x-scalix-class:IPM.Meeting.Resp.Neg OR x-scalix-class:IPM.Meeting.Resp.Pos OR x-scalix-class:IPM.Meeting.Resp.Tent OR x-scalix-class:IPM.Meeting.Canceled)</query><folders><included_folders/><excluded_folders><folder name="Public Folders/*"/><folder name="Other Users/*"/></excluded_folders></folders></m:search></SOAP-ENV:Body></SOAP-ENV:Envelope>

Analyzing filter criteria I can see now why it does not return anything as this (subject:IS NULL OR BODY:IS NULL OR location:IS NULL OR from:IS NULL OR to:IS NULL OR cc:IS NULL OR bcc:IS NULL) will never return anything.

But in addition to that if you enter as ONLY CRITERIA to show all events in next 6 months SWA sends this query

<?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/1999/XMLSchema" xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Header><credentials xmlns="http://scalix.com/schemas/gofish" SOAP-ENV:mustUnderstand="1"><username>sxadmin</username><fugu>Ox7c714e5b603234342e24292825232f2c28342206</fugu><ts>1466431508</ts></credentials></SOAP-ENV:Header><SOAP-ENV:Body><m:search xmlns:m="http://scalix.com/methods"><query>(subject:IS NULL OR BODY:IS NULL OR location:IS NULL OR from:IS NULL OR to:IS NULL OR cc:IS NULL OR bcc:IS NULL) AND (x-scalix-class:IPM.Schedule.Meeting.Request OR x-scalix-class:IPM.Appointment OR x-scalix-class:IPM.Meeting.Resp.Neg OR x-scalix-class:IPM.Meeting.Resp.Pos OR x-scalix-class:IPM.Meeting.Resp.Tent OR x-scalix-class:IPM.Meeting.Canceled)</query><folders><included_folders/><excluded_folders><folder name="Public Folders/*"/><folder name="Other Users/*"/></excluded_folders></folders></m:search></SOAP-ENV:Body></SOAP-ENV:Envelope>

Where you can see the date range criteria is absolutely diregarded.

The only option you have is to enter something in the free text box and eventually end up with this request:

<?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/1999/XMLSchema" xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Header><credentials xmlns="http://scalix.com/schemas/gofish" SOAP-ENV:mustUnderstand="1"><username>sxadmin</username><fugu>Ox7c714e5b603234342e24292825232f2c28342206</fugu><ts>1466431508</ts></credentials></SOAP-ENV:Header><SOAP-ENV:Body><m:search xmlns:m="http://scalix.com/methods"><query>(subject:asdfsdfaadfs OR BODY:asdfsdfaadfs OR location:asdfsdfaadfs OR from:asdfsdfaadfs OR to:asdfsdfaadfs OR cc:asdfsdfaadfs OR bcc:asdfsdfaadfs) AND (x-scalix-class:IPM.Schedule.Meeting.Request OR x-scalix-class:IPM.Appointment OR x-scalix-class:IPM.Meeting.Resp.Neg OR x-scalix-class:IPM.Meeting.Resp.Pos OR x-scalix-class:IPM.Meeting.Resp.Tent OR x-scalix-class:IPM.Meeting.Canceled)</query><folders><included_folders/><excluded_folders><folder name="Public Folders/*"/><folder name="Other Users/*"/></excluded_folders></folders></m:search></SOAP-ENV:Body></SOAP-ENV:Envelope>

... where "asdfsdfaadfs" was my entered text.

Calendar searches SHOULD return something at every search if search criteria is valid (date range, sensitivity ecc.) but as far as I can see those filters are not even parsed.

#4

Updated by Alexey Bobyr over 3 years ago

yes it was a root cause of issue.
I have changed it. now if it does not have value in searchFiled input it will not build query (body: is null or body: '') it just skepp it. also date range proper worked only during searching simple emails. for calendar items and contacts it ignored. Labels for calendar also ignored - I have not tested with latest changes.

searching by wildcard does not worked for emails(not app, contacts ) because it automatically quoted instead of simple '*' it build query with '"*"'.

and so on. Most of this issues are old.

Andrea Lanfranchi wrote:

When search dialog appears a search starts ! This is ineludible.
Analyzing call requests with Fiddler I can see SWA to send this request:

[...]

Analyzing filter criteria I can see now why it does not return anything as this (subject:IS NULL OR BODY:IS NULL OR location:IS NULL OR from:IS NULL OR to:IS NULL OR cc:IS NULL OR bcc:IS NULL) will never return anything.

But in addition to that if you enter as ONLY CRITERIA to show all events in next 6 months SWA sends this query
[...]

Where you can see the date range criteria is absolutely diregarded.

The only option you have is to enter something in the free text box and eventually end up with this request:
[...]

... where "asdfsdfaadfs" was my entered text.

Calendar searches SHOULD return something at every search if search criteria is valid (date range, sensitivity ecc.) but as far as I can see those filters are not even parsed.

#5

Updated by Alexey Bobyr over 3 years ago

  • Status changed from Updated to Resolved

I hope I have covered all things for search ...
fixes in scalix-swa_12.6.0.17691

#6

Updated by Alexey Bobyr over 3 years ago

after some tests there are new version of swa with several small fixes for search dialog 12.6.0.17693 will be available in a few days to download.

Alexey Bobyr wrote:

I hope I have covered all things for search ...
fixes in scalix-swa_12.6.0.17691

Also available in: Atom PDF