Project

General

Profile

Bug #60465

ActiveSyncTimeZone.fromVTimeZone NullPointerException

Added by Alexey Bobyr over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Alexey Bobyr
Category:
Scalix Wireless
Target version:
Start date:
06/01/2016
Due date:
06/03/2016
% Done:

100%

Estimated time:
Operation System:
--

Description

2016-05-31 15:46:04,061  WARN [HttpRequestHandler.handleRequest:176] SERVLET - deviceId: ASUSt1457787378597, user: xxx.xxxx@xxxx.com -  Unable to send response to
 client: null
2016-05-31 15:46:04,066  WARN [WirelessServlet.doPost:113] SERVLET - deviceId: ASUSt1457787378597, user: xxx.xxx@scalix.com - Uncaught and unhandled exception was 
reported by the server: 
A00000 unknown error
 Message:java.lang.NullPointerException

 Stacktrace:
[Ljava.lang.StackTraceElement;@88f846
        at com.scalix.wireless.HttpRequestHandler.handleRequest(HttpRequestHandler.java:177)
        at com.scalix.wireless.WirelessServlet.doPost(WirelessServlet.java:106)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:650)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:731)
        at org.springframework.web.servlet.mvc.ServletWrappingController.handleRequestInternal(ServletWrappingController.java:158)
        at org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:147)
        at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:50)
        at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:959)
        at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:893)
        at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:968)
        at org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:870)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:650)
        at org.springframework.web.servlet.FrameworkServlet.service(FrameworkServlet.java:844)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:731)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.springframework.web.filter.AbstractRequestLoggingFilter.doFilterInternal(AbstractRequestLoggingFilter.java:220)
        at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:107)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:220)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:169)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
        at org.apache.catalina.valves.StuckThreadDetectionValve.invoke(StuckThreadDetectionValve.java:221)
        at org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:270)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:436)
        at org.apache.coyote.ajp.AjpNioProcessor.process(AjpNioProcessor.java:175)
        at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:625)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1749)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1708)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException
        at net.fortuna.ical4j.model.component.Observance.getLatestOnset(Observance.java:169)
        at com.scalix.wireless.utils.ActiveSyncTimeZone.fromVTimeZone(ActiveSyncTimeZone.java:131)
        at com.scalix.message.formatter.CalendarFormatter.determineTimeZone(CalendarFormatter.java:589)
        at com.scalix.message.formatter.CalendarFormatter.formatMessage(CalendarFormatter.java:1108)
        at com.scalix.wireless.controller.command.SyncCommand.outputCalendarMessage(SyncCommand.java:555)
> at com.scalix.wireless.controller.command.SyncCommand.createWirelessOutputFormat(SyncCommand.java:343)
        at com.scalix.wireless.controller.command.SyncCommand.doSync(SyncCommand.java:225)
        at com.scalix.wireless.controller.command.SyncCommand.execute(SyncCommand.java:132)
        at com.scalix.wireless.handlers.WirelessRequestImpl.execute(WirelessRequestImpl.java:228)
        at com.scalix.wireless.HttpRequestHandler.handleRequest(HttpRequestHandler.java:136)

History

#1

Updated by Alexey Bobyr over 3 years ago

increased log levels for appointments.

Alexey Bobyr wrote:

[...]

#2

Updated by Alexey Bobyr over 3 years ago

  • Status changed from New to In Progress

finally got appointment

BEGIN:VCALENDAR
CALSCALE:GREGORIAN
PRODID:-//Scalix Corporation//Scalix Server 12.6.0.14880//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:(GMT-03:00)
BEGIN:STANDARD
DTSTART:16010101T230000
TZOFFSETFROM:-0200
TZOFFSETTO:-0300
RRULE:FREQ=YEARLY;BYDAY=3SU;BYMONTH=2
END:STANDARD
BEGIN:DAYLIGHT
TZOFFSETFROM:-0300
TZOFFSETTO:-0200
RRULE:FREQ=YEARLY;BYDAY=4SU;BYMONTH=10
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
UID:434847373.721463521617825.JavaMail.root(a)mail.scalix.com
LAST-MODIFIED:20160523T173105Z
DTSTAMP:20160523T173105Z
DTSTART;TZID="(GMT-03:00)":20160523T140000
DTEND;TZID="(GMT-03:00)":20160523T143000
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-MICROSOFT-CDO-IMPORTANCE:1
PRIORITY:5
TRANSP:OPAQUE
X-MICROSOFT-CDO-BUSYSTATUS:BUSY
SEQUENCE:0
SUMMARY: xxxxxxxx
X-SCALIX-LABEL:0
CLASS:PUBLIC
END:VEVENT
END:VCALENDAR

in test script ...

daylightComponent.getLatestOnset(new net.fortuna.ical4j.model.Date(c.getTimeInMillis()))
Exception in thread "main" java.lang.NullPointerException
    at net.fortuna.ical4j.model.component.Observance.getLatestOnset(Observance.java:169)
    at com.company.Main.main(Main.java:580)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at com.intellij.rt.execution.application.AppMain.main(AppMain.java:144)

investigating

#3

Updated by Alexey Bobyr over 3 years ago

In DAYLIGHT component missing

DTSTART:16010101T000000
#5

Updated by Alexey Bobyr over 3 years ago

  • Due date set to 06/03/2016
  • Status changed from In Progress to Resolved
  • Target version changed from 12.7 to Scalix 12.6
  • % Done changed from 0 to 100

ignoring DAYLIGHT if DTSTART is not specified .

https://tools.ietf.org/html/rfc5545

     The "STANDARD" or "DAYLIGHT" sub-component MUST
      include the "DTSTART", "TZOFFSETFROM", and "TZOFFSETTO" 
      properties.

wireless-12.6.0.15584
swa-12.6.0.17686

Also available in: Atom PDF