Project

General

Profile

Feature #60294

jre 1.9 support

Added by Alexey Bobyr over 3 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Alexey Bobyr
Category:
-
Target version:
Start date:
03/10/2016
Due date:
% Done:

0%

Estimated time:
Operation System:
--

Description

ubuntu 16.04 has in repository

openjdk-9-jre/xenial 9~b102-1 amd64
OpenJDK Java runtime, using Hotspot JIT

oracle-java9-installer/xenial,xenial,now 9b102+9b102arm-1~webupd8~0 all [installed]
Oracle Java(TM) Development Kit (JDK) 9

History

#1

Updated by Alexey Bobyr over 3 years ago

  • Status changed from New to Rejected

with jre 1.9 tomcat not starting.
[root@test logs]# java -version
java version "9-ea"
Java(TM) SE Runtime Environment (build 9-ea+110)
Java HotSpot(TM) 64-Bit Server VM (build 9-ea+110, mixed mode)

catalina.out logs
-Djava.endorsed.dirs=/opt/scalix-tomcat/endorsed is not supported. Endorsed standards and standalone APIs
in modular form will be supported via the concept of upgradeable modules.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

[root@test logs]# cat /etc/redhat-release
CentOS Linux release 7.2.1511 (Core)

current scalix-tomcat wont work with jre 1.9

#2

Updated by Alex I over 3 years ago

  • Target version changed from Scalix 12.6 to 12.7

moved to 12.7 then

#3

Updated by Alexey Bobyr over 3 years ago

  • Target version changed from 12.7 to Scalix 12.6

with current tomcat we can not support jre 1.9. Also jre 1.9 is availlabe only at 'Java Early Access Downloads'
from
https://jaxenter.com/java-9-release-date-announced-116945.html

2016-09-22 General Availability – Final release, ready for production use

#4

Updated by Alexey Bobyr about 2 years ago

  • Subject changed from try to install jre 1.9 and let's see scalix works or not to jre 1.9 support
  • Status changed from Rejected to Resolved
  • Target version changed from Scalix 12.6 to 12.7

Also available in: Atom PDF