Project

General

Profile

Bug #60154

exception during message removal

Added by Alexey Bobyr almost 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Alexey Bobyr
Category:
Scalix API
Target version:
Start date:
12/02/2015
Due date:
% Done:

0%

Estimated time:
Operation System:
noarch package

Description

2015-12-02 05:00:04,323  WARN [RestServlet.sendError:28] Sending error
I00004 could not delete message
        at com.scalix.api.mailbox.Mailbox.deleteMessage(Mailbox.java:1367)
        at com.scalix.api.rest.MailboxServlet.doDelete(MailboxServlet.java:950)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:656)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:731)
        at org.springframework.web.servlet.mvc.ServletWrappingController.handleRequestInternal(ServletWrappingController.java:158)
        at org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:146)
        at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:50)
        at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:943)
        at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:877)
        at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:966)
        at com.scalix.api.PlatformDispatcherServlet.service(PlatformDispatcherServlet.java:71)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:731)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.springframework.web.filter.AbstractRequestLoggingFilter.doFilterInternal(AbstractRequestLoggingFilter.java:214)
        at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:107)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:220)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:170)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
        at org.apache.catalina.valves.StuckThreadDetectionValve.invoke(StuckThreadDetectionValve.java:221)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:423)
        at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1079)
        at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:625)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1760)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1719)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
        at java.lang.Thread.run(Thread.java:745)
Caused by: javax.mail.MessageRemovedException: Messages have been removed
        at com.sun.mail.imap.IMAPFolder.setFlags(IMAPFolder.java:993)
        at com.scalix.api.imap.Imap.deleteMessage(Imap.java:1922)
        at com.scalix.api.mailbox.Mailbox.deleteMessage(Mailbox.java:1362)
        ... 35 more

History

#1

Updated by Alexey Bobyr almost 4 years ago

  • Status changed from Answered to Closed

Ignoring MessageRemovedException when deleting email - proboly someone else delete it and it does not exists anymore.

Alexey Bobyr wrote:

[...]

#2

Updated by Alex I about 3 years ago

  • Subject changed from exception during deleting message to exception during message removal

Also available in: Atom PDF