Project

General

Profile

Bug #60096

No such file or directory ERRORs in Scalix server log for Calendar items

Added by Richard Hall almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Richard Hall
Category:
Scalix Server
Target version:
Start date:
11/12/2015
Due date:
11/13/2015
% Done:

100%

Estimated time:
Operation System:
noarch package

Description

I see quite a few "No such file or directory" ERRORs for Calendar items generated for the browsers (MIME and Index) and also IMAP.

They are related to the updating of Calendar items, either changing the meeting/appointment or even just dismissing a reminder.

These errors seem to be spurious and do not cause any problem but should be not generated.

omshowlog output:

ERROR Browser (Mime_Browser ) 11.06.15 12:08:41
[SYS 2] No such file or directory
File Name: /var/opt/scalix/sm/s/data/0000012/0000l1g
Current errno value: 2
Last Msg Id: 1480889.141446807359590.JavaMail.root(a)scandium.test.scalix.com
Last Msg DirectRef: 00012002e31bed35
> sfl_GetNewOFilesEntry
<
sfl_GetNewOFilesEntry
> im_OpenItem
-> im_ItemRef2FName
-> FormItemName
-> im_FormDomainName
<
im_FormDomainName
> os_ul2str
<
os_ul2str
> os_ul2str
<
os_ul2str
<- FormItemName
<- im_ItemRef2FName
<- /build/12.5.2/src/lib/ombase/os/os_open.c:120[1,2]
<- /build/12.5.2/src/lib/ombase/sfl/sfl_base.c:369[1,2]
<- /build/12.5.1/src/lib/msl/msl_mimeout.c:101[1,2]

ERROR Browser (Index_Browser ) 11.06.15 12:11:05
[SYS 2] No such file or directory
File Name: /var/opt/scalix/sm/s/data/0000012/0000l1g
Current errno value: 2
Last Msg Id: 1480889.141446807359590.JavaMail.root(a)scandium.test.scalix.com
Last Msg DirectRef: 00012002e31bed35
> sfl_GetNewOFilesEntry
<
sfl_GetNewOFilesEntry
> im_OpenItem
-> im_ItemRef2FName
-> FormItemName
-> im_FormDomainName
<
im_FormDomainName
> os_ul2str
<
os_ul2str
> os_ul2str
<
os_ul2str
<- FormItemName
<- im_ItemRef2FName
<- /build/12.5.2/src/lib/ombase/os/os_open.c:120[1,2]
<- /build/12.5.2/src/lib/ombase/sfl/sfl_base.c:369[1,2]
<- /build/12.5.2/src/lib/ombase/im/im_UnlnItm.c:80[1,2]

History

#1

Updated by Richard Hall almost 4 years ago

Problem caused by the regeneration of MIME when the Calendar item is changed. If this is attempted by 2 processes at the same time a spurious error report can be generated when a old object file file is removed is has already been deleted.

Making a change to suppress the generation of MAPI-related object files by the item.browse process as this are not required for indexing.

#svn commit
Sending msl/msl_readcont.c
Transmitting file data .
Committed revision 14849.

#2

Updated by Richard Hall almost 4 years ago

  • Due date set to 11/13/2015
  • Status changed from Answered to Resolved
  • % Done changed from 0 to 100

Still getting ERRORs so further investigation.

Errors generated by mime creation when concurrent access of calendar items. SWA update of calendar item causes SFL item to be added and old item deleted. This deleted item is not handled correctly by msl and sfl libraries and generates errors/warnings and leaves a lock on the SFL file. These fixes will affect anything that can generate MIME from a calendar item: local.delivery, IMAP, mime.browse and index.browse.

This may be the cause of the locking problem reported in bug #50040 (FBS involvement is a red herring I think).

#svn commit
Sending lib/msl/msl_convert.c
Sending lib/ombase/sfl/sfl_Items.c
Transmitting file data ..
Committed revision 14853.

Also available in: Atom PDF