Project

General

Profile

Bug #60076

exception while parsing search query

Added by Alexey Bobyr almost 4 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Alexey Bobyr
Category:
Scalix SIS
Target version:
Start date:
11/09/2015
Due date:
11/09/2015
% Done:

100%

Estimated time:
Operation System:
--

Description

2015-11-04 13:16:08,379  WARN [ajp-nio-8009-exec-82] [SearchEngine.searchContent:296] Failed to parse user query SearchQuery{query='[lalala]', folderList=[000da2400e2476be], folderMode=INC, flagsList=null, sortOrder=null, reverse=false, rawScore=true, maxResult=-1, locale=en_US}
org.apache.lucene.queryparser.classic.ParseException: Cannot parse '[lalala]': Encountered " "]" "] "" at line 1, column 6.
Was expecting one of:
    "TO" ...
    <RANGE_QUOTED> ...
    <RANGE_GOOP> ...

        at org.apache.lucene.queryparser.classic.QueryParserBase.parse(QueryParserBase.java:125)
        at com.scalix.search.engine.QueryUtil.createContentQuery(QueryUtil.java:93)
        at com.scalix.search.engine.SearchEngine.searchContent(SearchEngine.java:294)
        at com.scalix.search.engine.SearchEngine.search(SearchEngine.java:166)
        at com.scalix.search.web.InternalSearchServlet.doSearch(InternalSearchServlet.java:192)
        at com.scalix.search.web.InternalSearchServlet.doGet(InternalSearchServlet.java:148)
        at com.scalix.search.web.InternalSearchServlet.doPost(InternalSearchServlet.java:120)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:650)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:731)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at com.scalix.sis.web.IPFilter.doFilter(IPFilter.java:68)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:220)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)
        at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:505)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:170)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
        at org.apache.catalina.valves.StuckThreadDetectionValve.invoke(StuckThreadDetectionValve.java:221)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:423)
        at org.apache.coyote.ajp.AjpNioProcessor.process(AjpNioProcessor.java:175)
        at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:625)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1760)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1719)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
        at java.lang.Thread.run(Unknown Source)
Caused by: org.apache.lucene.queryparser.classic.ParseException: Encountered " "]" "] "" at line 1, column 6.

History

#1

Updated by Alexey Bobyr almost 4 years ago

Removing "[" "]" if ParseException occurs and query does not have ":"

Alexey Bobyr wrote:

[...]

#2

Updated by Alex I about 3 years ago

  • Subject changed from search fails with query='[____]' with org.apache.lucene.queryparser.classic.ParseException: Encountered " "]" "] "" at line 1, column 6 to exception while parsing search query
  • Operation System set to --

Also available in: Atom PDF