Project

General

Profile

Bug #50013

Server 12.1.0 deb7 dependencies need updating for 32bit, 64bit, ldap, mailx and others

Added by Danny T over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Danny T
Category:
Scalix Server
Target version:
Start date:
10/21/2015
Due date:
10/21/2015
% Done:

100%

Estimated time:
Operation System:
--

Description

Steps to reproduce:
Get latest server deb and check dependencies, e.g. scalix-server_12.1.0.14382_i386.deb7.deb

Actual results:
Depends: bash, gawk, sed, util-linux, openssl, postfix | sendmail, libstdc++6, scalix-libical (>= 0.27.20071008), scalix-chardet (>= 1.0.20071031), procps, w3m, libkrb53, libsasl2, libsasl2-modules, libxml2, libglib2.0-0, postfix | sendmail-cf, libmilter0 | libmilter1, mailx

Expected results:
To be confirmed, but something more up to date with debian 7.2

Note: this may be similar and applicable to ubuntu12 build as well

History

#1

Updated by Danny T over 4 years ago

Something like the followings:

Pre-Depends: bash,
gawk,
util-linux,
openssl:amd64 | openssl:i386,
sendmail:all,
libstdc++6:i386 (>= 4.7.2-5),
scalix-libical (>= 0.27.20071008),
scalix-chardet (>= 1.0.20071031),
procps,
w3m,
libkrb5-3:i386 (>= 1.10.1),
libsasl2-2:i386 (>= 2.1.25),
libsasl2-modules:i386 (>= 2.1.25),
libxml2:i386 (>= 2.8.0),
libglib2.0-0:i386 (>= 2.33.12),
sendmail-cf:all,
libmilter1.0.1:i386 (>= 1.0.1),
mailutils:i386 | mailutils:amd64

plus may be libldap and mailx as well

#2

Updated by Richard Hall over 4 years ago

Changed as follows:

Package: scalix-server
Status: install ok installed
Priority: optional
Section: Scalix
Installed-Size: 80648
Maintainer:
Architecture: i386
Version: 12.1.0.14388
Provides: scalix-server
Pre-Depends: bash, gawk, util-linux, openssl:i386 | openssl:amd64, sendmail, libstdc++6:i386 (>= 4.7.2-5), scalix-libical (>= 0.27.20071008), scalix-chardet (>= 1.0.20071031), procps, w3m, libkrb5-3:i386 (>= 1.10.1), libsasl2-2:i386 (>= 2.1.25), libsasl2-modules:i386 (>= 2.1.25), libxml2:i386 (>= 2.8.0), libglib2.0-0:i386 (>= 2.33.12), sendmail-cf, libmilter1.0.1:i386 (>= 1.0.1), mailutils:i386 | mailutils:amd64
Description: Scalix-server is an enterprise class messaging server
ISSUE-DATE=2009-09-30

#4

Updated by Danny T over 4 years ago

------------------------------------------------------------------------
r14467 | danny | 2014-01-31 14:14:40 +0000 (Fri, 31 Jan 2014) | 2 lines

remove bash from server deps for ubuntu12 and deb7 to prevent x64 uninstall

#5

Updated by Danny T over 4 years ago

scalix-server-12.1.0.14467-1.rhel5.i386.rpm
scalix-server-12.1.0.14467-1.rhel6.i686.rpm
scalix-server-12.1.0.14467-1.sles10.i586.rpm
scalix-server-12.1.0.14467-1.sles11.i586.rpm
scalix-server-12.1.0.14467-1.suse12.i586.rpm
scalix-server-12.1.0.14467-1.suse13.i586.rpm
scalix-server_12.1.0.14467_i386.deb7.deb
scalix-server_12.1.0.14467_i386.ubuntu12.deb

Closing

#6

Updated by Danny T over 4 years ago

Hello all.
We have issues with one of our Scalix customer's server.
After updating to Scalix 12.0.3 on the server, it had troubles with sisindexer.
We have changed some Tomcat server settings and the problem partly was solved, but now there is another problem - the Tomcat should be restarted every 24 hours.
That's part of the log catalina.out:
...
Jan 9, 2014 6:30:03 PM org.apache.catalina.loader.WebappClassLoader clearReferencesThreads
SEVERE: The web application [/webmail] is still processing a request that has yet to finish. This is very likely to create a memory leak. You can control the time allowed for requests to finish by using the unloadDelay attribute of the standard Context implementation.
...
Jan 9, 2014 6:30:15 PM org.apache.catalina.loader.WebappClassLoader checkThreadLocalMapForLeaks
SEVERE: The web application [/sis] created a ThreadLocal with key of type [java.lang.ThreadLocal] (value [java.lang.ThreadLocal@480143e8]) and a value of type [org.apache.lucene.index.SegmentTermEnum] (value [org.apache.lucene.index.SegmentTermEnum@4b115946]) but failed to remove it when the web application was stopped. This is very likely to create a memory leak.
...
I set maxThreads option for Tomcat to 750 (which is quite a large value), but it didn't helped a lot.
As we found out with Alexey Bobyr reason for this is most likely in mod_proxy - it caches queries and tries to recover them after Tomcat restarting.
But I have a suspicion that the garbage collector can't handle. It is possible that the Scalix server has considerable memory leak,
and how to check it?
This is a very important issue, for a long time we have constant problems with the client's server.

#7

Updated by Danny T over 4 years ago

ok

#8

Updated by Danny T over 4 years ago

It's not memory leak in server, because sis indexer is java application...
maybe it has sense to replace url in sis-related configs to not use modproxy_ajp and go directly to tomcat url ?

#9

Updated by Danny T over 4 years ago

as an option we could try to use apache mod_jk instead of mod_ajp(mod_proxy).

#10

Updated by Volodymyr Tomash over 4 years ago

  • Due date set to 10/21/2015
  • Status changed from Answered to Resolved
  • % Done changed from 0 to 100
#11

Updated by Volodymyr Tomash over 4 years ago

  • Due date set to 10/21/2015
  • Status changed from Answered to Resolved
  • % Done changed from 0 to 100
#12

Updated by Volodymyr Tomash over 4 years ago

  • Subject changed from https://bugzilla.scalix.com/show_bug.cgi?id=50013 to Server 12.1.0 deb7 dependencies need updating for 32bit, 64bit, ldap, mailx and others
#13

Updated by Danny T almost 4 years ago

  • Status changed from Resolved to Closed

moved to closed - fixed before 12.6.0

Also available in: Atom PDF