Project

General

Profile

Bug #50005

Error integrate Scalix and AD.

Added by Volodymyr Tomash over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Alex I
Category:
LDAP(AD)
Target version:
Start date:
10/21/2015
Due date:
10/21/2015
% Done:

100%

Estimated time:
Operation System:
--

Description

Created attachment 1 [details]
Caa log

Error when trying to integrate Scalix and AD:
Output of "omldapsync -i AD_SX1 -d 6" :

INPUT: Attempt to test data extraction now y/n (n):y
2013-10-25 18:14:13 INFO: test searching from test.local ...
2013-10-25 18:14:13 INFO: search base is cn=users,dc=test,dc=local
2013-10-25 18:14:14 INFO: ... test searched OK.
2013-10-25 18:14:14 INFO: test listing servers from http://sxmail.test.local:8080/caa/ ...
2013-10-25 18:14:14 DEBUG: >>>>>>>>GetServersList.xml
2013-10-25 18:14:14 vvvvvvvv
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<SOAP-ENV:Body>
<scalix-caa:CAARequestMessage xmlns:scalix-caa="http://www.scalix.com/caa">
<ServiceType>scalix.res</ServiceType>
<FunctionName>GetServersList</FunctionName>
<Credentials id="12345">
<Identity name="" passwd="xxxxxxxx"/>
</Credentials>
<ScalixServers></ScalixServers>
<GetServersListParameters/>
</scalix-caa:CAARequestMessage>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>
2013-10-25 18:14:14 ^^^^^^
2013-10-25 18:14:14 DEBUG: >>>>>>>>OMCLASSPATH=/opt/scalix/bin/../server/java/lib/j2ee.jar:/opt/scalix/bin/../server/java/lib/saaj-api.jar:/opt/scalix/bin/../server/java/lib/saaj-impl.jar:/opt/scalix/bin/../server/java/lib/xercesImpl.jar
--------> Sending SOAP Request to Ubermanager@http://sxmail.test.local:8080/caa/ for method:GetServersList
SOAP part:

<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<SOAP-ENV:Body>
<scalix-caa:CAARequestMessage xmlns:scalix-caa="http://www.scalix.com/caa">
<ServiceType>scalix.res</ServiceType>
<FunctionName>GetServersList</FunctionName>
<Credentials id="12345">
<Identity name="" passwd="xxxxxxxx"/>
</Credentials>
<ScalixServers/>
<GetServersListParameters/>
</scalix-caa:CAARequestMessage>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>
--------> Received SOAP Response from Ubermanager@http://sxmail.test.local:8080/caa/
SOAP part:

<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<SOAP-ENV:Body>
<SOAP-ENV:Fault>
<faultcode>SOAP-ENV:Server</faultcode>
<faultstring>CAA Service Error</faultstring>
<detail>
<scalix-caa:fault-details xmlns:scalix-caa="http://www.scalix.com/caa">
<message>com.sun.xml.internal.messaging.saaj.soap.impl.TextImpl cannot be cast to javax.xml.soap.SOAPBodyElement</message>
<errorcode>CAA-101</errorcode>
</scalix-caa:fault-details>
</detail>
</SOAP-ENV:Fault>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>
error: Response contains failure report
2013-10-25 18:14:15 ERROR: failed to run omldapagent
2013-10-25 18:14:15 STATUS: Configuration of AD_SX1 failed, error=2 ##########
_________

Connecting to AD is successful (2013-10-25 18:14:13 INFO: search base is cn=users,dc=test,dc=local and 2013-10-25 18:14:14 INFO: ... test searched OK.)
However, synchronization with Scalix Server is not happening.
I tried to change the settings (IM_HOST,IM_CAA_URL,IM_CAA_ID and IM_CAA_PASS) and try to test on x86 and x86_64 OS. The result was the same.
Maybe the problem is in settings.

If you have any ideas how to solve this problem - show please.

caa.log is added.

Also available in: Atom PDF